Calendar

四月 2010
« 三月   五月 »
 1234
567891011
12131415161718
19202122232425
2627282930  

Categories

i7 860 + MSI BIG BANG-FUZION 做超頻

CPU Intel Core i7 860
RAM G.SKILL DDR3 2200 4GB (2GBx2) CL7 PIS
Motherboard MSI BIG BANG-FUZION
Cooler Thermalright TRUE BLACK 120 Rev.C + TR-FDB-12-1600
Power Seasonic X-750 80Plus Gold
Case Lian-li PC-B71
VGA ASUS ENGTX260/HTDI/896M

目前還在測試中所以無圖,
但已有一些心得和數據。

基本上我的目的是以能長期 run 但又不要加高電壓為主,
訴求就是低壓低溫的前提下獲得的最高時脈,
所以不會像某些論壇上那樣動不動就上 4GHz。
不過 i7 860 這顆 CPU 的超頻潛力真的不差,
原本我只把目標放在 18% 左右的超頻 (3.3GHz),
但卻一個不小心的來到了 3.7GHz 的 33% 領域。

這次選這片板子主要是因為我的 PCI-E 卡很多。
一堆 P55 的板子只要全部 x16 的 PCI-E 槽有 active 就會降到 x8 x8 x8,
這片可以維持在 x16 x8 x8,
加上 eSATA port 跟 SATA port 數量等考量就沒選 ASUS 那片 P7P55 WS Supercomputer,
所以就買了 MSI 這片板子。
因為這無聊的理由就花了大錢還嘗試去買 MSI 的板子?
要這樣說我也不想反駁。

對以往都是 ASUS 產品用下來的我來說這次換 MSI 的板子是一種新嘗試,
畢竟從以前就對 MSI 沒什麼好印象,
加上有一些內幕消息指出他們的工程師背景很好玩
但萬元以上的板子聽說是北工和雲科畢業的人做的 (好像其中一個是課長),
這聽起來就比較讓人能放心一點。

首先我不得不笑一下他們的 OC Genie 按鈕。
我按下去開機他居然給我直上 4GHz
而且 Windows 7 還開都開不起來直接卡死,
就是那個底下全黑上面會跑動畫 logo 的連跑都沒跑就 halt 住了,
而且還是主機板整個當了
我連按 reset 跟 power 都沒有反應,
當時簡直是快要笑死了
我想這大概是偵測 RAM 的 X.M.P. 時脈選出來的 BCLK 和外頻吧,
網路上看很多人插 1600 ~ 1800 的超出來的時脈都還正常。
好吧...
反正我一開始也不是很期待和信任這種全自動的東西,
畢竟只是想產生一個參考電壓值和相關數據才按的。

再來要笑的就是 BIOS 的 X.M.P.
BCLK 選 183 我是沒有什麼意見啦,
外頻選 18 得到 183x18 = 3294MHz 我也是沒什麼意見。
但重點就在於電壓實在加太猛了:

Vcore 1.45V (原始 0.9V)
VTT 1.351V (原始 1.126V)
PLL 1.8V (原始 1.8V)
PCH 1.529V (原始 1.064V)
DRAM 1.68V (原始 1.53V,X.M.P. 2200MHz 7-10-10-28 是 1.65V)

第一個我要笑的是南橋電壓加了 0.5V 不知道是在玩什麼,
我以前超頻好像從來沒有對南橋加什麼壓,
ASUS 的 BIOS 也不給我多少空間加南橋的壓。
南橋電壓開了 X.M.P. 就自動加壓到 1.529V 成了究極之謎
難道我是要對硬碟做超頻嗎?

第二個我要笑的就是 VTT。
MSI 這片板子其實有隨附六本手冊,
其中有兩本是超頻手冊,
手冊上的表格明明寫 BCLK 180~200 的時候 VTT 是 1.174~1.319V,
BCLK 才 183 就給我上 1.351V 是怎樣?
這我實在是不太明白啊...
手冊上那個超頻設定參考表跟 BIOS 可以不同調到這種地步。

第三個我要笑的就是 Vcore。
拜託人家網路上 1.26V 就能穩跑 3.8GHz,
先不說手冊上寫 BCLK 180~220 就要 1.3~1.375V 這件事,
只是開個 X.M.P. 就 Vcore 送了 1.45V 是怎樣?
更不要提加了這麼多壓才超到 3.2GHz。

聽說他們公司在測工程版 CPU 的只要 1.10V 就能穩上 BCLK 220。
這個說法我是沒有辦法證實,
基本上我的盒裝版跑 185x20,
在 BIOS 設 Vcore 1.10V 會被自動 reboot 3 次當超頻失敗論,
大概要 1.136V 以上才有辦法進 POST 畫面。

他們的 OC Dashboard 是蠻好用的,
開著機就能直接在上面按電壓看溫度,
讓我蠻容易找到會當機或讓 sp2004 算錯的底線電壓。

但是那個 OC Dashboard 上的電壓值跟 BIOS 設定的不一樣,
聽說跟 CPU-Z 一樣是從 SMBus 抓的。
總之 CPU 滿載的時候電壓值會高出一點,
這時 OC Dashboard 的電壓值也會跟著跳上去,
常常按完電壓值退出去以後再進去會看到電壓值有小偏。
總之一直把電壓減下去減到會當的話,
可能要往上跳三格 (0.024V) 再設進 BIOS 才有辦法開進 OS。

我現在 target 是定在 55℃ 以內能穩跑 185x20 = 3700MHz,
QPI ratio 我很大膽的開 x18。
雖說有人告訴我 i7 隨便都 220,
各大 forum 上也有一堆人說隨便就 200,
但我還是比較喜歡用跟 X.M.P. 抓出來的數據相近的值。
目前蹲在電腦旁慢慢按 OC Dashboard 按出來的數據大致上是這樣:

Vcore 1.20V
VTT 1.142V
PLL 1.8V
PCH 1.064V
DRAM 1.68V

DRAM 我是乖乖的照 BIOS 開 X.M.P. 後送的電壓來加壓,
比官方規格多了 0.03V,
因為不這麼做的話 sp2004 很容易出現 error。
另外這條 RAM 應該是不用肖想在 1.65V ~ 1.68V 下 command rate 跑 1N,
sp2004 開八個跑下去一小時內應該就看得到出現 1 ~ 2 個 error。

VTT 我目前是看不出來加不加壓有什麼差異,
所以意思意思小加壓了 0.016V 到 1.142V。
外國 forum 上有人說它跟 DRAM 不能差超過 0.5V,
比方說 VTT 1.1V 的話 DRAM 就不能超過 1.6V,
原理我是不太清楚所以對此說法存疑。

至於 Vcore 就是一個比較特殊的地方了。
因為這片主機板沒有辦法直接設定北橋電壓,
而 P55 架構因為北橋已經做進 CPU 內了,
所以我研判加壓在 Vcore 上應該也能算是同時對北橋加壓吧?

這個故事就比較長了。
我有一個 ATEN CS-1764 的 4-port DVI KVM,
新機器當然也是接在這下面。
我發現 Vcore 設在 1.168V 左右時,
不切換 KVM 的話跑 8 個 sp2004 跑 15 小時都沒事,
但是把 KVM 切來切去的話很容易造成 0x00000116 的 BSoD 出現;
至於 1.153V 的話 KVM 切過去畫面會先黑掉一陣子才有畫面出來,
常切也是會當掉。
查了一下 Google 發現這問題是 Vista & Windows 7 才會有的,
應該是 Windows 提供一種 kernel API 讓 driver 做 bug checking,
driver 認為有 bug 出現的時可以要求把 OS 整個 crash 掉。
反正我不是 M$ 平台的 programmer 所以也只能用猜的。

Vista & Windows 7 用這麼久了我多少也會抓 BSoD 的關鍵字,
總而言之關鍵字就以下三組:
GRAPHICS_DRIVER_TDR_FAULT
0x00000116
nvlddmkm.sys
丟去 Google 搜尋會發現要做的事情就是:
1. 更新 nvidia 的 driver (這我早就做了)
2. 抓 nvidia 的 system tools 調整顯卡風扇轉速
3. 用 regedit 去改一些東西關掉那個 bugcheck
4. 加壓或降頻
5. 換別的顯卡用

總之我查了很多資料之後決定先把機器設回標準時脈跟電壓跑跑看,
也就是 CPU 2.8GHz + RAM 1333MHz 這樣上。
sp2004 八個跑滿,
KVM 切來切去跑了 5 小時沒發生任何問題。
不過無線 USB 鍵盤滑鼠在這種滿載狀況時 KVM 切過去要好幾十秒才能動作,
這點在超頻的狀態下也會發生,
所以可以確定不是超頻的問題。

既然正常時脈不會有 0x116 的 BSoD 發生,
那麼就可以確定不是 nvidia 的卡和 driver 的問題。
試著加壓 VTT 後也是沒什麼作用,
於是我就懷疑到直接和 PCI-E 連接的北橋身上。
但是北橋已經做進 CPU 裡了,
BIOS 也沒有對北橋加電壓的選項,
我就只好對 Vcore 加壓看看,
畢竟 1.168V 相較於網路上看到的數據來說還是有點低。

順帶一提,
我手邊 1KVA 的 UPS 負載能力是 750W,
Vcore 每加壓約 0.01V 全速運轉的話 UPS 負載就會增加 1%,
所以用很單純的計算方式算下來大概每 0.01V 會吃掉 7.5W 的電吧。
機箱內跑滿載溫度的話大概是每 0.02V 會增加 1℃,
所以老實說加壓起來還是有點痛的,
但為求穩定還是得加壓。

目前我把 Vcore 加壓到 1.20V (滿載的時候板子會自動加到 1.224V),
0x116 的 BSoD 是沒再發生,
但是 KVM 切換過去時有一定機率螢幕會黑一下再跳回來,
或是跳出顯示卡驅動程式已停止回應並已恢復的訊息。
就我猜測可能是因為還沒到達 driver 設定的 timed out 時間,
所以 driver 還沒選擇要把系統 crash 掉,
因此就某種程度上來說,
Vcore 加壓到 1.20V 已經勉強能算是穩定了?
目前滿載在 23℃ 的冷氣房,
CPU 是 54℃,
System 36℃ (這是主機板溫度還是什麼的我就不清楚了),
DrMOS 平均約 55℃ (根據 MIS 手冊上說這溫度可以讓它的電容活 200 年以上)。

總而言之就先跑個一陣子再說吧,
如果確定這個參數只剩下這個問題了,
會考慮再加一點壓看看能不能完全跟沒加壓一樣順。
但是如果要我加壓到 1.45V 才能得到那種效果的話,
我想還是算了...
看是要接受這種不是很重要的小延遲,
還是乾脆把 CPU 的倍頻往回退一格。

目前測出來的電壓值大致上就是這樣了。
順便補充一下,
其實我也有點忘記當初 DRAM 為什麼調到 1.68V 了,
晚點會降回去 1.65V 再測一次,
照理說 1.65V 不會過的話可以 RMA 了吧?
另外 QPI ratio 是走到最後一步才從 x16 改到 x18,
因為想說電壓都加了那麼多了應該沒差。


Update: 2010-04-27
結果這個電壓還是當在 0x116,
凌晨覺得很誇張又回去用原時脈不超頻去燒機,
發現一樣 0x116。
這個看起來應該是 Windows 7 或 nvidia driver 的 bug,
接下來做一些測試還是無效後,
可能會採用 regedit 方案加長 timedout 間隔或直接 disable bugcheck 來試試看吧。
如果是這樣的話搞不好 1.20V 以下還是有機會的。

regedit 的相關參考資訊在這:
http://www.microsoft.com/whdc/device/display/wddm_timeout.mspx
不過看起來似乎是給 vista 用的,
不確定 windows 7 行不行。