Calendar

五月 2010
« 四月   八月 »
 12
3456789
10111213141516
17181920212223
24252627282930
31  

Categories

mod_gnutls 0.5.6 是地雷

Apache 2.2.12 以上已 native support 了 SNI,不再需要另裝 mod_gnutls 支援。
本篇文章內容已過時,只剩下考古的作用。
新資訊請參考:Apache 從 2.2.12 開始支援 SNI

最近發現這個相關的關鍵字跑進這篇的人變多了,
所以稍微提醒一下。
基本上 mod_gnutls 0.5.5 在我的 FreeBSD 8.0 + apache-worker 2.2.1x + php-5.2.1x/5.3.2 都是 work 的,
但是一升到 0.5.6 就會看到一堆 Segmentation fault 狂當當得很爽。
所以用相同環境的請勿亂升,
downgrade 回 0.5.5 就沒事了。

--
2010-08-06 Update
0.5.7 還是爆炸,
所以請繼續安心使用 0.5.5。
另外請注意,
在 FreeBSD 裝 0.5.7 必須裝 security/gnutls-devel,
用較舊的 security/gnutls 是不會過 configure 的。
反正 0.5.7 還是地雷所以先不詳述。